CRAN Package Check Results for Package driveR

Last updated on 2021-04-16 22:50:55 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.1 12.26 160.26 172.52 OK
r-devel-linux-x86_64-debian-gcc 0.2.1 11.15 123.68 134.83 OK
r-devel-linux-x86_64-fedora-clang 0.2.1 214.95 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.1 214.28 OK
r-devel-windows-ix86+x86_64 0.2.1 28.00 118.00 146.00 ERROR
r-devel-windows-x86_64-gcc10-UCRT 0.2.1 OK
r-patched-linux-x86_64 0.2.1 12.68 147.92 160.60 OK
r-patched-solaris-x86 0.2.1 301.40 NOTE
r-release-linux-x86_64 0.2.1 12.87 147.43 160.30 OK
r-release-macos-x86_64 0.2.1 NOTE
r-release-windows-ix86+x86_64 0.2.1 30.00 201.00 231.00 NOTE
r-oldrel-macos-x86_64 0.2.1 ERROR

Check Details

Version: 0.2.1
Check: installed package size
Result: NOTE
     installed size is 5.5Mb
     sub-directories of 1Mb or more:
     data 1.7Mb
     extdata 3.2Mb
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-windows-ix86+x86_64, r-patched-solaris-x86, r-release-macos-x86_64, r-release-windows-ix86+x86_64

Version: 0.2.1
Check: tests
Result: ERROR
     Running 'testthat.R' [20s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(driveR)
     >
     > test_check("driveR")
     == Failed tests ================================================================
     -- Error (test-core_functions.R:66:5): `create_features_df` works --------------
     Error: namespace 'rtracklayer' 1.48.0 is being loaded, but >= 1.51.5 is required
     Backtrace:
     x
     1. +-testthat::expect_is(...) test-core_functions.R:66:4
     2. | \-testthat::quasi_label(enquo(object), label, arg = "object")
     3. | \-rlang::eval_bare(expr, quo_get_env(quo))
     4. +-driveR::create_features_df(...)
     5. | \-driveR:::create_gene_level_scna_df(scna_df = scna_df, gene_overlap_threshold = gene_overlap_threshold)
     6. | \-base::suppressMessages(GenomicFeatures::genes(TxDb.Hsapiens.UCSC.hg19.knownGene::TxDb.Hsapiens.UCSC.hg19.knownGene))
     7. | \-base::withCallingHandlers(...)
     8. \-base::loadNamespace(x)
     9. +-base::namespaceImportFrom(...)
     10. | \-base::asNamespace(ns)
     11. \-base::loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]])
     -- Error (test-utility.R:19:5): `create_gene_level_scna_df` works --------------
     Error: namespace 'rtracklayer' 1.48.0 is being loaded, but >= 1.51.5 is required
     Backtrace:
     x
     1. +-testthat::expect_is(...) test-utility.R:19:4
     2. | \-testthat::quasi_label(enquo(object), label, arg = "object")
     3. | \-rlang::eval_bare(expr, quo_get_env(quo))
     4. +-driveR:::create_gene_level_scna_df(example_scna_table)
     5. | \-base::suppressMessages(GenomicFeatures::genes(TxDb.Hsapiens.UCSC.hg19.knownGene::TxDb.Hsapiens.UCSC.hg19.knownGene))
     6. | \-base::withCallingHandlers(...)
     7. \-base::loadNamespace(x)
     8. +-base::namespaceImportFrom(...)
     9. | \-base::asNamespace(ns)
     10. \-base::loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]])
     -- Error (test-utility.R:39:1): (code run outside of `test_that()`) ------------
     Error: namespace 'rtracklayer' 1.48.0 is being loaded, but >= 1.51.5 is required
     Backtrace:
     x
     1. +-driveR:::create_gene_level_scna_df(example_scna_table) test-utility.R:39:0
     2. | \-base::suppressMessages(GenomicFeatures::genes(TxDb.Hsapiens.UCSC.hg19.knownGene::TxDb.Hsapiens.UCSC.hg19.knownGene))
     3. | \-base::withCallingHandlers(...)
     4. \-base::loadNamespace(x)
     5. +-base::namespaceImportFrom(...)
     6. | \-base::asNamespace(ns)
     7. \-base::loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]])
    
     [ FAIL 3 | WARN 1 | SKIP 0 | PASS 20 ]
     Error: Test failures
     Execution halted
Flavor: r-devel-windows-ix86+x86_64

Version: 0.2.1
Check: package dependencies
Result: ERROR
    Packages required but not available:
     'TxDb.Hsapiens.UCSC.hg19.knownGene', 'org.Hs.eg.db'
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-macos-x86_64