CRAN Package Check Results for Package ClustAssess

Last updated on 2021-07-29 00:49:00 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.1 OK
r-devel-linux-x86_64-debian-gcc 0.1.1 22.41 90.49 112.90 OK
r-devel-linux-x86_64-fedora-clang 0.1.1 194.78 OK
r-devel-linux-x86_64-fedora-gcc 0.1.1 183.32 OK
r-devel-windows-x86_64 0.1.1 32.00 143.00 175.00 OK
r-devel-windows-x86_64-gcc10-UCRT 0.1.1 OK
r-patched-linux-x86_64 0.1.1 26.04 111.80 137.84 OK
r-patched-solaris-x86 0.1.1 233.90 OK
r-release-linux-x86_64 0.1.1 27.78 111.97 139.75 OK
r-release-macos-arm64 0.1.1 WARN
r-release-macos-x86_64 0.1.1 OK
r-release-windows-ix86+x86_64 0.1.1 78.00 200.00 278.00 OK
r-oldrel-macos-x86_64 0.1.1 OK
r-oldrel-windows-ix86+x86_64 0.1.1 51.00 167.00 218.00 ERROR

Check Details

Version: 0.1.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
     ...
    --- re-building ‘ClustAssess.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    Quitting from lines 22-27 (ClustAssess.Rmd)
    Error: processing vignette 'ClustAssess.Rmd' failed with diagnostics:
    polygon edge not found
    --- failed re-building ‘ClustAssess.Rmd’
    
    --- re-building ‘comparing-soft-and-hierarchical.Rmd’ using rmarkdown
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) not available. Falling back to R Markdown v1.
    Quitting from lines 23-36 (comparing-soft-and-hierarchical.Rmd)
    Error: processing vignette 'comparing-soft-and-hierarchical.Rmd' failed with diagnostics:
    polygon edge not found
    --- failed re-building ‘comparing-soft-and-hierarchical.Rmd’
    
    SUMMARY: processing the following files failed:
     ‘ClustAssess.Rmd’ ‘comparing-soft-and-hierarchical.Rmd’
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-release-macos-arm64

Version: 0.1.1
Check: running examples for arch ‘i386’
Result: ERROR
    Running examples in 'ClustAssess-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: marker_overlap
    > ### Title: Cell-wise marker gene overlap
    > ### Aliases: marker_overlap
    >
    > ### ** Examples
    >
    > suppressWarnings({
    + set.seed(12345)
    + library(Seurat)
    +
    + # cluster with Louvain algorithm
    + pbmc_small = FindClusters(pbmc_small, resolution=0.8, verbose=FALSE)
    +
    + # cluster with k-means
    + pbmc.pca = Embeddings(pbmc_small, 'pca')
    + pbmc_small@meta.data$kmeans_clusters = kmeans(pbmc.pca, centers=2)$cluster
    +
    + # compare the markers
    + Idents(pbmc_small) = pbmc_small@meta.data$seurat_clusters
    + louvain.markers = FindAllMarkers(pbmc_small, logfc.threshold=1, verbose=FALSE)
    +
    + Idents(pbmc_small) = pbmc_small@meta.data$kmeans_clusters
    + kmeans.markers = FindAllMarkers(pbmc_small, logfc.threshold=1, verbose=FALSE)
    +
    + pbmc_small@meta.data$jsi = marker_overlap(louvain.markers, kmeans.markers,
    + pbmc_small@meta.data$seurat_clusters, pbmc_small@meta.data$kmeans_clusters)
    +
    + # which cells have the same markers, regardless of clustering?
    + FeaturePlot(pbmc_small, 'jsi')
    + })
    Error: package or namespace load failed for 'Seurat' in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
     namespace 'Matrix' 1.3-2 is already loaded, but >= 1.3.3 is required
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64

Version: 0.1.1
Check: running examples for arch ‘x64’
Result: ERROR
    Running examples in 'ClustAssess-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: marker_overlap
    > ### Title: Cell-wise marker gene overlap
    > ### Aliases: marker_overlap
    >
    > ### ** Examples
    >
    > suppressWarnings({
    + set.seed(12345)
    + library(Seurat)
    +
    + # cluster with Louvain algorithm
    + pbmc_small = FindClusters(pbmc_small, resolution=0.8, verbose=FALSE)
    +
    + # cluster with k-means
    + pbmc.pca = Embeddings(pbmc_small, 'pca')
    + pbmc_small@meta.data$kmeans_clusters = kmeans(pbmc.pca, centers=2)$cluster
    +
    + # compare the markers
    + Idents(pbmc_small) = pbmc_small@meta.data$seurat_clusters
    + louvain.markers = FindAllMarkers(pbmc_small, logfc.threshold=1, verbose=FALSE)
    +
    + Idents(pbmc_small) = pbmc_small@meta.data$kmeans_clusters
    + kmeans.markers = FindAllMarkers(pbmc_small, logfc.threshold=1, verbose=FALSE)
    +
    + pbmc_small@meta.data$jsi = marker_overlap(louvain.markers, kmeans.markers,
    + pbmc_small@meta.data$seurat_clusters, pbmc_small@meta.data$kmeans_clusters)
    +
    + # which cells have the same markers, regardless of clustering?
    + FeaturePlot(pbmc_small, 'jsi')
    + })
    Error: package or namespace load failed for 'Seurat' in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
     namespace 'Matrix' 1.3-2 is already loaded, but >= 1.3.3 is required
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64

Version: 0.1.1
Check: re-building of vignette outputs
Result: WARN
    Error(s) in re-building vignettes:
    --- re-building 'ClustAssess.Rmd' using rmarkdown
    Quitting from lines 22-27 (ClustAssess.Rmd)
    Error: processing vignette 'ClustAssess.Rmd' failed with diagnostics:
    package or namespace load failed for 'Seurat' in loadNamespace(j <- i[[1L]], c(lib.loc, .libPaths()), versionCheck = vI[[j]]):
     namespace 'Matrix' 1.3-2 is already loaded, but >= 1.3.3 is required
    --- failed re-building 'ClustAssess.Rmd'
    
    --- re-building 'comparing-soft-and-hierarchical.Rmd' using rmarkdown
    --- finished re-building 'comparing-soft-and-hierarchical.Rmd'
    
    SUMMARY: processing the following file failed:
     'ClustAssess.Rmd'
    
    Error: Vignette re-building failed.
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64