CRAN Package Check Results for Package Patterns

Last updated on 2021-08-05 22:55:01 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.3 12.54 150.09 162.63 OK
r-devel-linux-x86_64-debian-gcc 1.3 12.34 114.60 126.94 OK
r-devel-linux-x86_64-fedora-clang 1.3 205.15 NOTE
r-devel-linux-x86_64-fedora-gcc 1.3 192.92 NOTE
r-devel-windows-x86_64 1.3 21.00 194.00 215.00 OK
r-devel-windows-x86_64-gcc10-UCRT 1.3 ERROR
r-patched-linux-x86_64 1.3 13.48 144.08 157.56 OK
r-patched-solaris-x86 1.3 295.10 NOTE
r-release-linux-x86_64 1.3 10.87 142.94 153.81 OK
r-release-macos-arm64 1.3 ERROR
r-release-macos-x86_64 1.3 ERROR
r-release-windows-ix86+x86_64 1.3 29.00 184.00 213.00 OK
r-oldrel-macos-x86_64 1.3 ERROR
r-oldrel-windows-ix86+x86_64 1.3 29.00 188.00 217.00 OK

Check Details

Version: 1.3
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘KernSmooth’ ‘Mfuzz’ ‘SelectBoost’ ‘gplots’ ‘grid’ ‘jetset’ ‘magic’
     ‘msgps’ ‘splines’ ‘stats4’ ‘survival’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86

Version: 1.3
Check: package dependencies
Result: ERROR
    Package required but not available: 'WGCNA'
    
    Package suggested but not available for checking: 'biomaRt'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 1.3
Check: package dependencies
Result: ERROR
    Packages required but not available: 'jetset', 'Mfuzz', 'WGCNA'
    
    Package suggested but not available for checking: ‘biomaRt’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-macos-arm64

Version: 1.3
Check: package dependencies
Result: ERROR
    Packages required but not available: 'jetset', 'Mfuzz', 'WGCNA'
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-macos-x86_64

Version: 1.3
Check: package dependencies
Result: ERROR
    Package required but not available: ‘Mfuzz’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-macos-x86_64