CRAN Package Check Results for Package enviGCMS

Last updated on 2019-08-22 22:46:53 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.5.5 5.00 62.45 67.45 NOTE
r-devel-linux-x86_64-debian-gcc 0.5.5 3.90 49.89 53.79 NOTE
r-devel-linux-x86_64-fedora-clang 0.5.7 79.11 NOTE
r-devel-linux-x86_64-fedora-gcc 0.5.7 79.70 NOTE
r-devel-windows-ix86+x86_64 0.5.5 15.00 171.00 186.00 OK
r-patched-linux-x86_64 0.5.5 5.47 66.54 72.01 OK
r-release-linux-x86_64 0.5.5 5.35 66.01 71.36 OK
r-release-windows-ix86+x86_64 0.5.5 20.00 168.00 188.00 OK
r-release-osx-x86_64 0.5.5 ERROR
r-oldrel-windows-ix86+x86_64 0.5.7 13.00 144.00 157.00 OK
r-oldrel-osx-x86_64 0.5.5 NOTE

Check Details

Version: 0.5.5
Check: for non-standard things in the check directory
Result: NOTE
    Found the following files/directories:
     'MSP' 'demomzrt.csv' 'test.gif'
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc

Version: 0.5.7
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: 'xcms', 'MSnbase'
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.5.7
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘broom’ ‘crosstalk’ ‘dplyr’ ‘ggraph’ ‘igraph’ ‘plotly’
     ‘rmarkdown’ ‘shinythemes’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.5.5
Check: package dependencies
Result: ERROR
    Packages required but not available: 'BiocParallel', 'genefilter'
    
    Packages suggested but not available for checking: 'xcms', 'MSnbase'
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-osx-x86_64

Version: 0.5.5
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: ‘xcms’ ‘MSnbase’
Flavor: r-oldrel-osx-x86_64

Version: 0.5.5
Check: dependencies in R code
Result: NOTE
    Namespaces in Imports field not imported from:
     ‘DT’ ‘broom’ ‘crosstalk’ ‘dplyr’ ‘ggraph’ ‘igraph’ ‘plotly’
     ‘rmarkdown’ ‘shinythemes’
     All declared Imports should be used.
Flavor: r-oldrel-osx-x86_64