CRAN Package Check Results for Package sparsebnUtils

Last updated on 2019-07-17 22:54:40 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.0.7 4.15 46.34 50.49 OK
r-devel-linux-x86_64-debian-gcc 0.0.7 2.67 36.34 39.01 OK
r-devel-linux-x86_64-fedora-clang 0.0.7 60.74 OK
r-devel-linux-x86_64-fedora-gcc 0.0.7 60.26 OK
r-devel-windows-ix86+x86_64 0.0.7 10.00 58.00 68.00 OK
r-patched-linux-x86_64 0.0.7 3.01 45.97 48.98 OK
r-patched-solaris-x86 0.0.7 92.10 OK
r-release-linux-x86_64 0.0.7 3.90 46.17 50.07 OK
r-release-windows-ix86+x86_64 0.0.7 6.00 75.00 81.00 OK
r-release-osx-x86_64 0.0.7 ERROR
r-oldrel-windows-ix86+x86_64 0.0.7 5.00 73.00 78.00 OK
r-oldrel-osx-x86_64 0.0.7 NOTE

Check Details

Version: 0.0.7
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: 'graph', 'RCy3'
Flavor: r-release-osx-x86_64

Version: 0.0.7
Check: Rd cross-references
Result: NOTE
    Packages unavailable to check Rd xrefs: ‘RCy3’, ‘graph’
Flavor: r-release-osx-x86_64

Version: 0.0.7
Check: tests
Result: ERROR
     Running ‘testthat.R’ [4s/4s]
    Running the tests in ‘tests/testthat.R’ failed.
    Last 13 lines of output:
     7: to_bn.edgeList(x$edges)
     8: to_bn(to_graphNEL(x))
     9: to_graphNEL(x)
     10: stop("graph package (from BioConductor) required to coerce data to 'graphNEL' type!",
     call. = FALSE)
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     OK: 265 SKIPPED: 3 WARNINGS: 0 FAILED: 4
     1. Error: (unknown) (@test-as.R#7)
     2. Error: (unknown) (@test-graphNEL.R#8)
     3. Error: Coercion works on empty graphs (@test-x-compatibility.R#32)
     4. Error: Coercion to bn works (@test-x-compatibility.R#108)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-release-osx-x86_64

Version: 0.0.7
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘RCy3’
Flavor: r-oldrel-osx-x86_64

Version: 0.0.7
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘RCy3’
Flavor: r-oldrel-osx-x86_64